e107 v0.555

admin by admin in

Here is the latest update, those of you running 0.554 only need the update zip.

Here is the latest update, those of you running 0.554 only need the update zip. You'll need to run upgrade.php as there are some minor changes to the stat_counter table.

This will be the last release for a while. The reason for this is that the next version of e107 will be radically different. e107 has evolved from it's beginnings as a simple script to the full blown cms it is today. I never imagined for a second it would get as popular as it has, and I'm proud every time I see a site using it, I really mean that. But the structure is so scrappy.

So the next version will be a radical departure. I'll be tidying the structure. adding better language support (language files on a per file basis as opposed to all lumped together as they are now), a decent plugin api, better path support, and most importantly a strong file structure. I'll do my best to keep everything as backward compatible as possible by writing a set of wrappers that will allow you to use existing plugins with the new structure.

I'll keep you informed as the the progress.

I'd just like to take a moment to thank everyone who has offered support in whatever way, e107 would never have grown to what it is today without your help and support. Be proud of yourselves, each and every one of you smile





This news item is from e107 v2 Bootstrap CMS
https://mail.static.e107.org/blog/384.html